Apps-madeingermany.de Forum

Welcome to my support forum

You are not logged in.

#1 2015-06-30 11:04:55

Vince_Vega
Member
Registered: 2015-06-30
Posts: 3

[Solved] Unable to install as system app

Hi,

I've tried to isntall GPS Fake Location yesterday as system app without xposed or mock locations.

And while i was able to move the app to system/app (cut from data/app, pasted into system/app as described) after i rebooted the phone (repeatedly) the app was still giving me the warning box, that it isn't running as system app, xposed not isntalled and mock locations not enabled.
i don't want to use xposed or enalbe mock locations.

Phone is rooted 4.4.4.

I'm certain i do it wrong somewhere, could someone point out my mistake to me?

Thanks!

Last edited by Vince_Vega (2015-07-02 13:08:26)

Offline

#2 2015-06-30 12:33:35

megamind
Member
From: Moskva
Registered: 2014-11-11
Posts: 33

Re: [Solved] Unable to install as system app

You need to get a root file explorer - mount r/w - and get the .apk  - move to system app (the real folder may be different "system/app" or "system/priv-app") - restart.

http://forum.apps-madeingermany.de/viewtopic.php?id=9

Last edited by megamind (2015-06-30 12:33:51)

Offline

#3 2015-06-30 13:26:35

Vince_Vega
Member
Registered: 2015-06-30
Posts: 3

Re: [Solved] Unable to install as system app

Yes i've read the article.

Ok, i might miss this step: "mount r/w"
Can i do this in ES explorer or do i have to have a shell app for that?

/Edit:
Update.
I deleted that previously copied APK from the system/app folder
- remounted system as rw (through terminal, can't find the option in ESFX)
- pasted the apk into system/app
- changed the rights to rwx r r (and tried rwx r-x r-x as well)
- rebooted the phone.

Still no success.
Am i copying into the right directory with KitKat 4.4.4 with system/app or does it have to go into system-priv-app (or whatever that is called?

Thansk a million!

Last edited by Vince_Vega (2015-06-30 15:52:50)

Offline

#4 2015-07-01 20:35:49

sammyjoe
Member
Registered: 2015-05-11
Posts: 8

Re: [Solved] Unable to install as system app

\system\priv-app

worked for me

then reboot - make sure you delete from \system\app if you put it there

Offline

#5 2015-07-02 11:48:00

Vince_Vega
Member
Registered: 2015-06-30
Posts: 3

Re: [Solved] Unable to install as system app

That was the solution.

For all the command line challenged people like me:
mount -o remount,rw /system   
Copy to to /system/priv-app

Thank you, working like a charm now.

Last edited by Vince_Vega (2015-07-02 13:09:59)

Offline

Board footer

Powered by FluxBB